import re
regex = re.compile(r"^([1-9]\d*|0) rows returned\.$", flags=re.MULTILINE)
test_str = ("0 rows returned.\n"
"1 rows returned.\n"
"10 rows returned.\n"
"1234 rows returned.\n"
"01 rows returned.\n"
"00 rows returned.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")