package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]\d*|0) rows returned\.$`)
var str = `0 rows returned.
1 rows returned.
10 rows returned.
1234 rows returned.
01 rows returned.
00 rows returned.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}