const regex = /^([1-9]\d*|0) rows returned\.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]\\d*|0) rows returned\\.$', 'gm')
const str = `0 rows returned.
1 rows returned.
10 rows returned.
1234 rows returned.
01 rows returned.
00 rows returned.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}