import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d*|0) rows returned\\.$";
final String string = "0 rows returned.\n"
+ "1 rows returned.\n"
+ "10 rows returned.\n"
+ "1234 rows returned.\n"
+ "01 rows returned.\n"
+ "00 rows returned.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}