re = /^([1-9]\d*|0) rows returned\.$/m
str = '0 rows returned.
1 rows returned.
10 rows returned.
1234 rows returned.
01 rows returned.
00 rows returned.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end