using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([1-9]\d*|0) rows returned\.$";
string input = @"0 rows returned.
1 rows returned.
10 rows returned.
1234 rows returned.
01 rows returned.
00 rows returned.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}