#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\{\{ *lang(?:ue)* *\|[^\|\}]*\|(?:[^\}']*''[^\}']*){1,3}\}\}"
Local $sString = "oui {{ langue |en|truc'' machin ''chose''}}" & @CRLF & _
"oui {{ langue |en|truc'' machin chose}}" & @CRLF & _
"oui {{lang| es |truc'' machin ''chose''}}" & @CRLF & _
"oui {{lang| es |truc'' machin ''chose'' ''bidule''}}" & @CRLF & _
"non {{lang| es |''truc'' machin ''chose''}}" & @CRLF & _
"non {{lien web|langue=es|''truc'' machin ''chose''}}" & @CRLF & _
"non ''{{lang| es |truc machin chose}}''"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")