import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{ *lang(?:ue)* *\\|[^\\|\\}]*\\|(?:[^\\}']*''[^\\}']*){1,3}\\}\\}";
final String string = "oui {{ langue |en|truc'' machin ''chose''}}\n"
+ "oui {{ langue |en|truc'' machin chose}}\n"
+ "oui {{lang| es |truc'' machin ''chose''}}\n"
+ "oui {{lang| es |truc'' machin ''chose'' ''bidule''}}\n"
+ "non {{lang| es |''truc'' machin ''chose''}}\n"
+ "non {{lien web|langue=es|''truc'' machin ''chose''}}\n"
+ "non ''{{lang| es |truc machin chose}}''";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}