// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\{\{ *lang(?:ue)* *\|[^\|\}]*\|(?:[^\}']*''[^\}']*){1,3}\}\}").unwrap();
let string = "oui {{ langue |en|truc'' machin ''chose''}}
oui {{ langue |en|truc'' machin chose}}
oui {{lang| es |truc'' machin ''chose''}}
oui {{lang| es |truc'' machin ''chose'' ''bidule''}}
non {{lang| es |''truc'' machin ''chose''}}
non {{lien web|langue=es|''truc'' machin ''chose''}}
non ''{{lang| es |truc machin chose}}''";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}