$re = '/\{\{ *lang(?:ue)* *\|[^\|\}]*\|(?:[^\}\']*\'\'[^\}\']*){1,3}\}\}/mi';
$str = 'oui {{ langue |en|truc\'\' machin \'\'chose\'\'}}
oui {{ langue |en|truc\'\' machin chose}}
oui {{lang| es |truc\'\' machin \'\'chose\'\'}}
oui {{lang| es |truc\'\' machin \'\'chose\'\' \'\'bidule\'\'}}
non {{lang| es |\'\'truc\'\' machin \'\'chose\'\'}}
non {{lien web|langue=es|\'\'truc\'\' machin \'\'chose\'\'}}
non \'\'{{lang| es |truc machin chose}}\'\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);