re = /\{\{ *lang(?:ue)* *\|[^\|\}]*\|(?:[^\}']*''[^\}']*){1,3}\}\}/mi
str = 'oui {{ langue |en|truc\'\' machin \'\'chose\'\'}}
oui {{ langue |en|truc\'\' machin chose}}
oui {{lang| es |truc\'\' machin \'\'chose\'\'}}
oui {{lang| es |truc\'\' machin \'\'chose\'\' \'\'bidule\'\'}}
non {{lang| es |\'\'truc\'\' machin \'\'chose\'\'}}
non {{lien web|langue=es|\'\'truc\'\' machin \'\'chose\'\'}}
non \'\'{{lang| es |truc machin chose}}\'\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end