package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\{\{ *lang(?:ue)* *\|[^\|\}]*\|(?:[^\}']*''[^\}']*){1,3}\}\}`)
var str = `oui {{ langue |en|truc'' machin ''chose''}}
oui {{ langue |en|truc'' machin chose}}
oui {{lang| es |truc'' machin ''chose''}}
oui {{lang| es |truc'' machin ''chose'' ''bidule''}}
non {{lang| es |''truc'' machin ''chose''}}
non {{lien web|langue=es|''truc'' machin ''chose''}}
non ''{{lang| es |truc machin chose}}''`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}