use strict;
my $str = 'oui {{ langue |en|truc\'\' machin \'\'chose\'\'}}
oui {{ langue |en|truc\'\' machin chose}}
oui {{lang| es |truc\'\' machin \'\'chose\'\'}}
oui {{lang| es |truc\'\' machin \'\'chose\'\' \'\'bidule\'\'}}
non {{lang| es |\'\'truc\'\' machin \'\'chose\'\'}}
non {{lien web|langue=es|\'\'truc\'\' machin \'\'chose\'\'}}
non \'\'{{lang| es |truc machin chose}}\'\'';
my $regex = qr/\{\{ *lang(?:ue)* *\|[^\|\}]*\|(?:[^\}']*''[^\}']*){1,3}\}\}/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}