const regex = new RegExp('\\{\\{ *lang(?:ue)* *\\|[^\\|\\}]*\\|(?:[^\\}\\']*\\'\\'[^\\}\\']*){1,3}\\}\\}', 'gmi')
const str = `oui {{ langue |en|truc'' machin ''chose''}}
oui {{ langue |en|truc'' machin chose}}
oui {{lang| es |truc'' machin ''chose''}}
oui {{lang| es |truc'' machin ''chose'' ''bidule''}}
non {{lang| es |''truc'' machin ''chose''}}
non {{lien web|langue=es|''truc'' machin ''chose''}}
non ''{{lang| es |truc machin chose}}''`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}