using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(')([^:,]+?)(')([^:,]+?)(')(:|,)";
        string substitution = @"$1$2\\'$4$5$6";
        string input = @"'statusid':'2000',
'country':'Hungary',
'pcode':'2000',
'city':'Budapest',
'street':'Route d'Arlon',
'houseno':'12',
'score':'100',
'gpslong':'6'09419',
'gpslat':'49'617081',
'a'a':'a',";
        
        Regex regex = new Regex(pattern);
        string result = regex.Replace(input, substitution);
    }
}