use strict;
my $str = '\'statusid\':\'2000\',
\'country\':\'Hungary\',
\'pcode\':\'2000\',
\'city\':\'Budapest\',
\'street\':\'Route d\'Arlon\',
\'houseno\':\'12\',
\'score\':\'100\',
\'gpslong\':\'6\'09419\',
\'gpslat\':\'49\'617081\',
\'a\'a\':\'a\',';
my $regex = qr/(')([^:,]+?)(')([^:,]+?)(')(:|,)/p;
my $subst = '$1$2\\\\\'$4$5$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";