import re
regex = re.compile(r"(')([^:,]+?)(')([^:,]+?)(')(:|,)")
test_str = ("'statusid':'2000',\n"
"'country':'Hungary',\n"
"'pcode':'2000',\n"
"'city':'Budapest',\n"
"'street':'Route d'Arlon',\n"
"'houseno':'12',\n"
"'score':'100',\n"
"'gpslong':'6'09419',\n"
"'gpslat':'49'617081',\n"
"'a'a':'a',")
subst = "$1$2\\\\'$4$5$6"
result = regex.sub(subst, test_str)
if result:
print(result)