import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(')([^:,]+?)(')([^:,]+?)(')(:|,)";
final String string = "'statusid':'2000',\n"
+ "'country':'Hungary',\n"
+ "'pcode':'2000',\n"
+ "'city':'Budapest',\n"
+ "'street':'Route d'Arlon',\n"
+ "'houseno':'12',\n"
+ "'score':'100',\n"
+ "'gpslong':'6'09419',\n"
+ "'gpslat':'49'617081',\n"
+ "'a'a':'a',";
final String subst = "$1$2\\\\'$4$5$6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}