# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^\s_]+_[^\s_]+\K_/x/gm;t' <<< "123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg"