import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s_]+_[^\\s_]+\\K_";
final String string = "123_456_789.jpg\n"
+ "3210_5325_aa.jpg\n"
+ "54321-0888_555_1111.jpg";
final String subst = "x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}