re = /^[^\s_]+_[^\s_]+\K_/m
str = '123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result