import Foundation
let pattern = #"^[^\s_]+_[^\s_]+\K_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)