const regex = /^[^\s_]+_[^\s_]+\K_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s_]+_[^\\s_]+\\K_', 'gm')
const str = `123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);