using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\s_]+_[^\s_]+\K_";
string substitution = @"x";
string input = @"123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}