use strict;
my $str = '123_456_789.jpg
3210_5325_aa.jpg
54321-0888_555_1111.jpg';
my $regex = qr/^[^\s_]+_[^\s_]+\K_/mp;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";