#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^\s_]+_[^\s_]+\K_"
Local $sString = "123_456_789.jpg" & @CRLF & _
"3210_5325_aa.jpg" & @CRLF & _
"54321-0888_555_1111.jpg"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)