const regex = /(?<=[^{])\-(?=[^{}]+}})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^{])\\-(?=[^{}]+}})', 'gm')
const str = `Hello {{first-name}}, how are you?
Hello {{first-name, last-name}}, how are you?
Hello {{-name, name-}} how are you?
Hello {{first}}-{{last}}, how are you?`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);