import re
regex = re.compile(r"(?<=[^{])\-(?=[^{}]+}})", flags=re.MULTILINE)
test_str = ("Hello {{first-name}}, how are you?\n"
"Hello {{first-name, last-name}}, how are you?\n"
"Hello {{-name, name-}} how are you?\n"
"Hello {{first}}-{{last}}, how are you?")
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)