$re = '/(?<=[^{])\-(?=[^{}]+}})/m';
$str = 'Hello {{first-name}}, how are you?
Hello {{first-name, last-name}}, how are you?
Hello {{-name, name-}} how are you?
Hello {{first}}-{{last}}, how are you?';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;