re = /(?<=[^{])\-(?=[^{}]+}})/m
str = 'Hello {{first-name}}, how are you?
Hello {{first-name, last-name}}, how are you?
Hello {{-name, name-}} how are you?
Hello {{first}}-{{last}}, how are you?'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result