import Foundation
let pattern = #"(?<=[^{])\-(?=[^{}]+}})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello {{first-name}}, how are you?
Hello {{first-name, last-name}}, how are you?
Hello {{-name, name-}} how are you?
Hello {{first}}-{{last}}, how are you?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)