using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\.*)";
string input = @"\x1b[31m42\x1b[0m
\x1b[32m1010\x1b[0m";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}