$re = '/(\\\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\\\.*)/m';
$str = '\\x1b[31m42\\x1b[0m
\\x1b[32m1010\\x1b[0m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);