use strict;
my $str = '\\x1b[31m42\\x1b[0m
\\x1b[32m1010\\x1b[0m';
my $regex = qr/(\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}