import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\x[0-9a-fA-F]+\\[\\d+m)([0-9\\.]+)(\\\\.*)";
final String string = "\\x1b[31m42\\x1b[0m\n"
+ "\\x1b[32m1010\\x1b[0m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}