re = /(\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\.*)/m
str = '\\x1b[31m42\\x1b[0m
\\x1b[32m1010\\x1b[0m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end