import re
regex = re.compile(r"(\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\.*)", flags=re.MULTILINE)
test_str = ("\\x1b[31m42\\x1b[0m\n"
"\\x1b[32m1010\\x1b[0m")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")