// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\\x[0-9a-fA-F]+\[\d+m)([0-9\.]+)(\\.*)").unwrap();
let string = "\\x1b[31m42\\x1b[0m
\\x1b[32m1010\\x1b[0m";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}