# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/brown(.*)$/white$1/gim;t' <<< "The quick brown fox jumped over the lazy white dog
first brown fox, second brown fox
"