re = /brown(.*)$/im
str = 'The quick brown fox jumped over the lazy white dog
first brown fox, second brown fox
'
subst = 'white$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result