import Foundation
let pattern = #"brown(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
The quick brown fox jumped over the lazy white dog
first brown fox, second brown fox
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"white$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)