use strict;
my $str = 'The quick brown fox jumped over the lazy white dog
first brown fox, second brown fox
';
my $regex = qr/brown(.*)$/imp;
my $subst = 'white$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";