const regex = new RegExp('brown(.*)$', 'gim')
const str = `The quick brown fox jumped over the lazy white dog
first brown fox, second brown fox
`;
const subst = `white$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);