# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^whatever=[^;]*; |; whatever=[^;]*)//gm;t' <<< "Cookie: header1=123; whatever=cookievalue1234; header2=789;"