using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^whatever=[^;]*; |; whatever=[^;]*)";
string substitution = @"";
string input = @"Cookie: header1=123; whatever=cookievalue1234; header2=789;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}