// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^whatever=[^;]*; |; whatever=[^;]*)").unwrap();
let string = "Cookie: header1=123; whatever=cookievalue1234; header2=789;";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}