#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^whatever=[^;]*; |; whatever=[^;]*)"
Local $sString = "Cookie: header1=123; whatever=cookievalue1234; header2=789;"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)