const regex = new RegExp('(^whatever=[^;]*; |; whatever=[^;]*)', 'gm')
const str = `Cookie: header1=123; whatever=cookievalue1234; header2=789;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);