$re = '`(^whatever=[^;]*; |; whatever=[^;]*)`m';
$str = 'Cookie: header1=123; whatever=cookievalue1234; header2=789;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;