re = /(^whatever=[^;]*; |; whatever=[^;]*)/m
str = 'Cookie: header1=123; whatever=cookievalue1234; header2=789;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result